Hitachi Vantara Pentaho Community Wiki
Skip to end of metadata
Go to start of metadata

AgileBI (as part of PDI 4.4) does not work on CentOS 6 out-of-the box. AgileBI relies on SWT 3.7 which is not compatible with the version of XULRunner that comes with CentOS 6.

You first need to download a version of XULRunner that will work. You can download archives from: 

  64bithttp://rpm.pbone.net/index.php3/stat/4/idpl/15779310/dir/fedora_13/com/xulrunner-1.9.2.17-2.fc13.x86_64.rpm.html
  32bithttp://rpm.pbone.net/index.php3/stat/4/idpl/15779168/dir/fedora_13/com/xulrunner-1.9.2.17-2.fc13.i686.rpm.html

You won't be able to install the rpm in the typical fashion, the default version of Firefox relies on the newer version of xulrunner. We really only need the contents of the rpm. to extract just the contents:

  $ cd <location you downloaded xulrunner to>
  $ sudo rpm2cpio xulrunner-1.9.2.17-2.fc13.<osArch>.rpm | cpio -idmv

That will extract xulrunner relative to the current dir. We only need some of what is extracted, lets move that to our home dir...

  $ mv ./usr/lib<osArch>/xulrunner-1.9.2 ~/xulrunner-1.9.2

*feel free to clean up the original extract folder after the move, we don't need it any more.

Now we need to tell Spoon that we want to use a different version of xulrunner than the default. Open <data-integration folder>/spoon.sh in a text editor like gedit.

  $ gedit <data-integration-home>/spoon.sh

modify the MOZILLA_FIVE_HOME setting to the new location of the 1.9.2 version of xulrunner, replace:

spoon.sh
MOZILLA_FIVE_HOME=$(find /usr/lib -maxdepth 1 -name xulrunner-[0-9]* | head -1)

with:

spoon.sh
MOZILLA_FIVE_HOME=$HOME/xulrunner-1.9.2

...

#also add a VM argument to the OPT var: -Dorg.eclipse.swt.browser.XULRunnerPath=$MOZILLA_FIVE_HOME
OPT="$OPT $PENTAHO_DI_JAVA_OPTIONS -Dorg.eclipse.swt.browser.XULRunnerPath=$MOZILLA_FIVE_HOME -Djava.library.path=$LIBPATH -DKETTLE_HOME=$KETTLE_HOME -DKETTLE_REPOSITORY=$KETTLE_REPOSITORY -DKETTLE_USER=$KETTLE_USER -DKETTLE_PASSWORD=$KETTLE_PASSWORD -DKETTLE_PLUGIN_PACKAGES=$KETTLE_PLUGIN_PACKAGES -DKETTLE_LOG_SIZE_LIMIT=$KETTLE_LOG_SIZE_LIMIT"

Now, we need to install a newer version of sqlite. You can download the sqlite bits from:

  64bit : http://pkgs.org/centos-6-rhel-6/atomic-x86_64/sqlite-3.7.0.1-1.el6.art.x86_64.rpm/download/
  32bit : http://pkgs.org/centos-6-rhel-6/atomic-i386/sqlite-3.7.0.1-1.el6.art.i686.rpm/download/

Install the 3.7 version of sqlite:

  sudo rpm -Uvh sqlite-3.7.0.1-1.el6.art.<osArch>.rpm
  sqlite3 --version

Your sqlite version should now be 3.7.0.1

Launch Spoon:

  cd <data-integration-home>
  ./spoon.sh
  • No labels