Hitachi Vantara Pentaho Community Wiki
Child pages
  • 01. Configuring Eclipse for XUL Development
Skip to end of metadata
Go to start of metadata

Configuring Eclipse for XUL Development

This guide assumes you have a relatively recent (3.2 or newer) version of Eclipse installed. If you don't have it, you can download it for free from http://www.eclipse.org/.

The only prerequisite for working with XUL is the XULrunner runtime environment. Installation instructions vary depending on platform. See the appropriate section below for your system.

Linux

All Linux distributions have this in their package managers, so simply add it as you would any other distro-supported software package. The XULrunner package must be at least version 1.8.13.

No further configuration is necessary.

Windows

  1. Download a zip file of a recent XULrunner SDK build. As of this writing, the latest XULrunner release is 1.9.0.0: http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.9.0.0/sdk/xulrunner-1.9.en-US.win32.sdk.zip
  2. Create a *C:\Program Files\xulrunner* directory.
  3. Unzip the XULrunner SDK to the directory you just created.

You will have to reference this location when running XUL documents.

Installing the XULbooster plugin for Eclipse

You can use any text editor to work with XUL files, but since the XUL DTD is strict, it's much easier to use an XML editor that is aware of the XUL standard. Check the capabilities of your preferred editor to see if it has XUL support, or if there is some kind of plugin or extension that can add XUL validation.

The XULbooster Eclipse plugin is what Pentaho developers use to work with the XUL framework. It provides validation and preview capabilities that are extremely helpful for developing XUL interface files for Pentaho applications.

XULbooster requires XULrunner as mentioned above, and the Eclipse IDE version 3.3 or newer. You can download Eclipse from http://www.eclipse.org/ – opt for the Classic package. Note that Linux package managers frequently have older versions of Eclipse that will not work correctly with XULbooster, so you may need to either uninstall the old version, or have two separate copies available. The Eclipse Web Tools Platform (WTP) version 2.0 or newer is also required; you should be able to install this through the standard Eclipse plugin sources.

Here is a comprehensive list of minimum requirements for XULbooster:

  • Java Development Kit (JDK) 1.5
  • Eclipse 3.3
  • WPT 2.0
  • XULrunner 1.8.13

To install XULbooster:

  1. Download the XULbooster package: http://sourceforge.net/project/showfiles.php?group_id=177536
  2. Start Eclipse.
  3. Go to the Help menu, then select Software Updates, then Find and Install...
  4. In the Install/Update window, click search for new features to install, then click Next.
  5. In the Install window, click New Archived Site...
  6. In the file dialog, navigate to the XULBooster zip file, select it, then click Ok.
  7. In the Edit Local Site window, click OK.
  8. Click Finish in the Install window.
  9. In the Updates window, click the XULbooster checkbox, then click Next.
  10. Select the radio button next to I accept the terms of the license agreements, then click Next.
  11. Click Finish.
  • No labels