Hitachi Vantara Pentaho Community Wiki

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Quick Start: Building the project

The Pentaho Big Data Plugin is built with Apache Ant and uses Apache Ivy for dependency management. You'll need Ant 1.8.0 or newer to build the project.

<TODO>

Code Block
svn co svn://source.pentaho.org/svnkettleroot/pentaho-big-data-plugin/trunk pentaho-big-data-plugin
cd pentaho-big-data-plugin
ant

Developing with Eclipse

We recommend Apache IvyDE to manage your Ivy dependencies within Eclipse.

  1. Import pentaho-big-data-plugin into Eclipse
  2. Resolve the project using IvyDE

If IvyDE is not an option then you can manually add the jars from lib/ and libswt/ to your class path. This project, like all other Pentaho projects, uses the open-source Subfloor Ant build framework. Running the following targets will create a .classpath with all the jars it resolves:

Code Block
ant resolve create-dot-classpath

Then import or refresh the project in Eclipse and add the SWT libraries for your architecture, e.g. for Mac OS X x64:
<TODO Image>