Problemas de configuración

La versión 1.6.0 de la Plataforma Pentaho y la PCI (Instalación Preconfigurada) pasaron a GA antes que Pentaho Data Integration y por lo tanto incluyen la versión 2.5.1 de PDI.

Esto significa que para correr transformaciones de la versión 3.0 en la plataforma es necesario hacer una actualización del componente Kettle para que utilice la nueva API 3.0.

La siguiente versión de la Plataforma Pentaho incluye en componente Kettle actualizado para trabajar con la versión 3.0.

Compilando el nuevo componente Kettle

Para modificar el código fuente de la Plataforma Pentaho para que ejecute transformaciones y trabajos de la versión 3 de PDI, ejecutar los siguientes pasos:

Eso debería permitir compilar la plataforma Pentaho y utilizarla para correr transformaciones y trabajos de Kettle 3.