There have been major bug fixes and some additional functionality introduced into the Big Data Plugin since the 5.0.1 Community Edition was released. These instructions will show you how to upgrade CE to the 5.0.4 version of the Big Data components.

If you are a customer using Pentaho Enterprise Edition, you do not need to follow these instructions. Call your support person for access to the official 5.0.4 patched software or go to support.pentaho.com

Alternatively, you may download and use the Pentaho Enterprise Edition 30 day Evaluation www.pentaho.com/testdrive which already has 5.0.4 and you will not have to follow these upgrade steps.

These steps are the same for updating Kettle Spoon, Pentaho Report Designer and Pentaho BA Server. The only difference is the folder in which files will be copied and is noted below.

It is assumed that you already have the 5.0.1 versions Pentaho CE products you are interested in upgrading. If not, you may download the Pentaho Community Edition from community.pentaho.com

Update steps

  1. Quit the application(s) you will be upgrading.
  2. Download the Pentaho Big Data Plugin 5.0.4 from support.
  3. Download the Pentaho Hadoop Hive JDBC Driver from support.
  4. Delete the Pentaho Big Data Plugin Plugin folder located:
  5. Unzip pentaho-big-data-plugin-5.0.4.zip into the folder where you deleted the 5.0.1 plugin. The unzip should have created a new pentaho-big-data-plugin folder.
  6. Delete the Pentaho Hadoop Hive JDBC Driver located:
  7. Copy pentaho-hadoop-hive-jdbc-shim-5.0.4.jar to the lib directory where you deleted the 5.0.1 version.

Extra fun for Mac OSX Mavericks users and Spoon

Dialog and UI issues There are known display and file open dialog issues with Kettle spoon on Mavericks. Updating to the latest SWT .jar file should resolve those issues.

  1. Quit Spoon
  2. Download the latest SWT Jar from support
  3. Replace the swt.jar located in data-integration/libswt/osx64 with the new one

Bad .app file If Mavericks complains about a broken or corrupt .app file, there is a new one available that is correctly configured.

  1. Quit Spoon
  2. Download the new Data Integration.app file from support
  3. Replace the Data Integration.app with the new one